re = /(<[^`]+>|<\/\w+>)/m
str = '<!DOCTYPE html>
<html>
<head>
<title>Hello</title>
</head>
<body>
<h1>hello</h1>
<h6>whatever</h6>
<p>this is a paragraph</p>
</body>
</html>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end