$re = '/(<[^`]+>|<\/\w+>)/m';
$str = '<!DOCTYPE html>
<html>
<head>
<title>Hello</title>
</head>
<body>
<h1>hello</h1>
<h6>whatever</h6>
<p>this is a paragraph</p>
</body>
</html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);