// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(<[^`]+>|<\/\w+>)").unwrap();
let string = "<!DOCTYPE html>
<html>
<head>
<title>Hello</title>
</head>
<body>
<h1>hello</h1>
<h6>whatever</h6>
<p>this is a paragraph</p>
</body>
</html>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}