#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<_KEY_1>[\w\.]+):(?<_VAL_1>[\w\.]+)"
Local $sString = " <vuln:vulnerable-software-list>" & @CRLF & _
" <vuln:product>cpe:/o:novell:opensuse:13.1</vuln:product>" & @CRLF & _
" <vuln:product>cpe:/a:samba:rsync:3.1.1</vuln:product>" & @CRLF & _
" <vuln:product>cpe:/o:novell:opensuse:13.2</vuln:product>" & @CRLF & _
" </vuln:vulnerable-software-list>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")