using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<_KEY_1>[\w\.]+):(?<_VAL_1>[\w\.]+)";
string input = @" <vuln:vulnerable-software-list>
<vuln:product>cpe:/o:novell:opensuse:13.1</vuln:product>
<vuln:product>cpe:/a:samba:rsync:3.1.1</vuln:product>
<vuln:product>cpe:/o:novell:opensuse:13.2</vuln:product>
</vuln:vulnerable-software-list>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}