use strict;
my $str = ' <vuln:vulnerable-software-list>
<vuln:product>cpe:/o:novell:opensuse:13.1</vuln:product>
<vuln:product>cpe:/a:samba:rsync:3.1.1</vuln:product>
<vuln:product>cpe:/o:novell:opensuse:13.2</vuln:product>
</vuln:vulnerable-software-list>';
my $regex = qr/(?<_KEY_1>[\w\.]+):(?<_VAL_1>[\w\.]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}