package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<_KEY_1>[\w\.]+):(?<_VAL_1>[\w\.]+)`)
var str = ` <vuln:vulnerable-software-list>
<vuln:product>cpe:/o:novell:opensuse:13.1</vuln:product>
<vuln:product>cpe:/a:samba:rsync:3.1.1</vuln:product>
<vuln:product>cpe:/o:novell:opensuse:13.2</vuln:product>
</vuln:vulnerable-software-list>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}