#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!-)\b[1-9]\d*\s+(left|remaining)"
Local $sString = "0 left" & @CRLF & _
"1 left" & @CRLF & _
"2 left" & @CRLF & _
"3 left" & @CRLF & _
"0 remaining" & @CRLF & _
"1 remaining" & @CRLF & _
"2 remaining" & @CRLF & _
"you have 3 left" & @CRLF & _
"(13 left)" & @CRLF & _
"there are 12 remaining today" & @CRLF & _
"You have (-12 left) today" & @CRLF & _
"There are (3 left)" & @CRLF & _
"-15 remaining today" & @CRLF & _
"you have -24 left today"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")