import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!-)\\b[1-9]\\d*\\s+(left|remaining)";
final String string = "0 left\n"
+ "1 left\n"
+ "2 left\n"
+ "3 left\n"
+ "0 remaining\n"
+ "1 remaining\n"
+ "2 remaining\n"
+ "you have 3 left\n"
+ "(13 left)\n"
+ "there are 12 remaining today\n"
+ "You have (-12 left) today\n"
+ "There are (3 left)\n"
+ "-15 remaining today\n"
+ "you have -24 left today";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}