import re
regex = re.compile(r"(?<!-)\b[1-9]\d*\s+(left|remaining)", flags=re.MULTILINE)
test_str = ("0 left\n"
"1 left\n"
"2 left\n"
"3 left\n"
"0 remaining\n"
"1 remaining\n"
"2 remaining\n"
"you have 3 left\n"
"(13 left)\n"
"there are 12 remaining today\n"
"You have (-12 left) today\n"
"There are (3 left)\n"
"-15 remaining today\n"
"you have -24 left today")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")