package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((?:oxygen|nitrogen|carbon_dioxide|toxins)\ ?\=\ ?.*?[;\}])`)
var str = `"bX" = (/obj/machinery/conveyor{dir = 2; id = "awaysyndie"},/turf/open/floor/plating{carbon_dioxide = 48.7; dir = 4; heat_capacity = 1e+006; icon_state = "warnplate"; nitrogen = 13.2; oxygen = 32.4; temperature = 251},/area/awaycontent/a4{has_gravity = 1; name = "Syndicate Outpost"})`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}