// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((?:oxygen|nitrogen|carbon_dioxide|toxins)\ ?\=\ ?.*?[;\}])").unwrap();
let string = "\"bX\" = (/obj/machinery/conveyor{dir = 2; id = \"awaysyndie\"},/turf/open/floor/plating{carbon_dioxide = 48.7; dir = 4; heat_capacity = 1e+006; icon_state = \"warnplate\"; nitrogen = 13.2; oxygen = 32.4; temperature = 251},/area/awaycontent/a4{has_gravity = 1; name = \"Syndicate Outpost\"})";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}