using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?=[#?]).*?[#?]|(?!.*?[#?])^|&)([^= \n]+?)=([^& \n]+?)(?=$|&)";
string input = @"path#key1=val1
path#key2=val2&key3=val3
.html?key4=val4&key5=val5
key=val&key6=val6";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}