const regex = /(?:(?=[#?]).*?[#?]|(?!.*?[#?])^|&)([^= \n]+?)=([^& \n]+?)(?=$|&)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:(?=[#?]).*?[#?]|(?!.*?[#?])^|&)([^= \\n]+?)=([^& \\n]+?)(?=$|&)', 'gm')
const str = `path#key1=val1
path#key2=val2&key3=val3
.html?key4=val4&key5=val5
key=val&key6=val6`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}