$re = '/(?:(?=[#?]).*?[#?]|(?!.*?[#?])^|&)([^= \n]+?)=([^& \n]+?)(?=$|&)/m';
$str = 'path#key1=val1
path#key2=val2&key3=val3
.html?key4=val4&key5=val5
key=val&key6=val6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);