re = /(?:(?=[#?]).*?[#?]|(?!.*?[#?])^|&)([^= \n]+?)=([^& \n]+?)(?=$|&)/m
str = 'path#key1=val1
path#key2=val2&key3=val3
.html?key4=val4&key5=val5
key=val&key6=val6'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end