import re
regex = re.compile(r"<Row>w+")
test_str = (" <Row>\n"
" <INVOICE_NUMBER>NULL</INVOICE_NUMBER>\n"
" <KOD_MATER>232820</KOD_MATER>\n"
" <KOD_EAN>4620008991313</KOD_EAN>\n"
" <SERIA>100</SERIA>\n"
" <D_BEGIN>224515001</D_BEGIN>\n"
" <D_END>224520000</D_END>\n"
" <EGAIS>0150117000001837067</EGAIS>\n"
" <N_ZAYAV>82</N_ZAYAV>\n"
" <N_GTD>NULL</N_GTD>\n"
" <MANUFACTURE>5029047184</MANUFACTURE>\n"
" <DATE_BOTTLING>24.07.2014</DATE_BOTTLING>\n"
" </Row>\n"
" <Row>\n"
" <INVOICE_NUMBER>NULL</INVOICE_NUMBER>\n"
" <KOD_MATER>232820</KOD_MATER>\n"
" <KOD_EAN>4620008991313</KOD_EAN>\n"
" <SERIA>100</SERIA>\n"
" <D_BEGIN>224520001</D_BEGIN>\n"
" <D_END>224525000</D_END>\n"
" <EGAIS>0150117000001837067</EGAIS>\n"
" <N_ZAYAV>82</N_ZAYAV>\n"
" <N_GTD>NULL</N_GTD>\n"
" <MANUFACTURE>5029047184</MANUFACTURE>\n"
" <DATE_BOTTLING>24.07.2014</DATE_BOTTLING>\n"
" </Row>")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")