// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<Row>w+").unwrap();
let string = " <Row>
<INVOICE_NUMBER>NULL</INVOICE_NUMBER>
<KOD_MATER>232820</KOD_MATER>
<KOD_EAN>4620008991313</KOD_EAN>
<SERIA>100</SERIA>
<D_BEGIN>224515001</D_BEGIN>
<D_END>224520000</D_END>
<EGAIS>0150117000001837067</EGAIS>
<N_ZAYAV>82</N_ZAYAV>
<N_GTD>NULL</N_GTD>
<MANUFACTURE>5029047184</MANUFACTURE>
<DATE_BOTTLING>24.07.2014</DATE_BOTTLING>
</Row>
<Row>
<INVOICE_NUMBER>NULL</INVOICE_NUMBER>
<KOD_MATER>232820</KOD_MATER>
<KOD_EAN>4620008991313</KOD_EAN>
<SERIA>100</SERIA>
<D_BEGIN>224520001</D_BEGIN>
<D_END>224525000</D_END>
<EGAIS>0150117000001837067</EGAIS>
<N_ZAYAV>82</N_ZAYAV>
<N_GTD>NULL</N_GTD>
<MANUFACTURE>5029047184</MANUFACTURE>
<DATE_BOTTLING>24.07.2014</DATE_BOTTLING>
</Row>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}