#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(?: # non-capturing group" & @CRLF & _
" \#summertime\b # match #summertime" & @CRLF & _
" | # or" & @CRLF & _
" \G(?<!^), # a comma not at the beginning of string and match it only if it's after the last match" & @CRLF & _
") # closing the non-capturing group" & @CRLF & _
"\s* # some optional whitespaces" & @CRLF & _
"\K # forget what we matched so far" & @CRLF & _
"[^\s,]+ # match anything that's not a whitespace nor a comma one or more times"
Local $sString = "#summertime swimming, running, tanning"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")