package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?: # non-capturing group
\#summertime\b # match #summertime
| # or
\G(?<!^), # a comma not at the beginning of string and match it only if it's after the last match
) # closing the non-capturing group
\s* # some optional whitespaces
\K # forget what we matched so far
[^\s,]+ # match anything that's not a whitespace nor a comma one or more times`)
var str = `#summertime swimming, running, tanning`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}