import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?: # non-capturing group\n"
+ " \\#summertime\\b # match #summertime\n"
+ " | # or\n"
+ " \\G(?<!^), # a comma not at the beginning of string and match it only if it's after the last match\n"
+ ") # closing the non-capturing group\n"
+ "\\s* # some optional whitespaces\n"
+ "\\K # forget what we matched so far\n"
+ "[^\\s,]+ # match anything that's not a whitespace nor a comma one or more times";
final String string = "#summertime swimming, running, tanning";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}