import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bclient_secret=[^&;]*";
final String string = "/search?q=tuition&btnG.x=0&btnG.y=0&site=transfer_credit&client=transfer_credit&proxystylesheet=transfer_credit&output=xml_no_dtd&proxycustom=HOME&client_secret=asdasdas&daskjdhakjhsd";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}