const regex = /\bclient_secret=[^&;]*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bclient_secret=[^&;]*', '')
const str = `/search?q=tuition&btnG.x=0&btnG.y=0&site=transfer_credit&client=transfer_credit&proxystylesheet=transfer_credit&output=xml_no_dtd&proxycustom=HOME&client_secret=asdasdas&daskjdhakjhsd`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}