// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\bclient_secret=[^&;]*").unwrap();
let string = "/search?q=tuition&btnG.x=0&btnG.y=0&site=transfer_credit&client=transfer_credit&proxystylesheet=transfer_credit&output=xml_no_dtd&proxycustom=HOME&client_secret=asdasdas&daskjdhakjhsd";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}