re = /\bclient_secret=[^&;]*/
str = '/search?q=tuition&btnG.x=0&btnG.y=0&site=transfer_credit&client=transfer_credit&proxystylesheet=transfer_credit&output=xml_no_dtd&proxycustom=HOME&client_secret=asdasdas&daskjdhakjhsd'
# Print the match result
str.match(re) do |match|
puts match.to_s
end