$re = '/(?<!\d)(?<!\d\.)\d+(?!\.?\d)/m';
$str = ' 15159970 (30.12.2015), 15615115 (01.01.1970), 11224455, 55441123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);