import re
regex = re.compile(r"(?<!\d)(?<!\d\.)\d+(?!\.?\d)", flags=re.MULTILINE)
test_str = " 15159970 (30.12.2015), 15615115 (01.01.1970), 11224455, 55441123"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")