re = /(?<!\d)(?<!\d\.)\d+(?!\.?\d)/m
str = ' 15159970 (30.12.2015), 15615115 (01.01.1970), 11224455, 55441123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end