const regex = new RegExp('\\d{1,2}?. (Januar|Februar|März|April|Mai|Juni|Juli|Augustus|September|Oktober|November|Dezember).(20\\d{1,2})', 'gm')
const str = `Dies iste in TExt 1. Oktober 2022. Hallo.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}