re = /\d{1,2}?. (Januar|Februar|März|April|Mai|Juni|Juli|Augustus|September|Oktober|November|Dezember).(20\d{1,2})/m
str = 'Dies iste in TExt 1. Oktober 2022. Hallo.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end