import re
regex = re.compile(r"\d{1,2}?. (Januar|Februar|März|April|Mai|Juni|Juli|Augustus|September|Oktober|November|Dezember).(20\d{1,2})", flags=re.MULTILINE)
test_str = ("Dies iste in TExt 1. Oktober 2022. Hallo.\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")