$re = '/\d{1,2}?. (Januar|Februar|März|April|Mai|Juni|Juli|Augustus|September|Oktober|November|Dezember).(20\d{1,2})/m';
$str = 'Dies iste in TExt 1. Oktober 2022. Hallo.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);