using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\bof\s+([^.]+)";
string input = @"Ole Abraham of XYZ becomes Chief Digital Officer and EVP, Business Development of Warner Music Group.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}