package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\bof\s+([^.]+)`)
var str = `Ole Abraham of XYZ becomes Chief Digital Officer and EVP, Business Development of Warner Music Group.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}