$re = '/.*\bof\s+([^.]+)/';
$str = 'Ole Abraham of XYZ becomes Chief Digital Officer and EVP, Business Development of Warner Music Group.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);