re = /.*\bof\s+([^.]+)/
str = 'Ole Abraham of XYZ becomes Chief Digital Officer and EVP, Business Development of Warner Music Group.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end