#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)<articles:loop.+>(:?.|\n|\r)+?<\/articles:loop>"
Local $sString = "<articles:loop count="4">" & @CRLF & _
"" & @CRLF & _
" <div>@Title@</div>" & @CRLF & _
"" & @CRLF & _
"</articles:loop>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")