package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)<articles:loop.+>(:?.|\n|\r)+?<\/articles:loop>`)
var str = `<articles:loop count="4">
<div>@Title@</div>
</articles:loop>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}