re = /<articles:loop.+>(:?.|\n|\r)+?<\/articles:loop>/mi
str = '<articles:loop count="4">
<div>@Title@</div>
</articles:loop>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end