import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\d{1,2}/\\\\w{4,9}\\\\((N|Naing|n|p|P|naing|Y|y|E|e)\\\\)\\\\d{5,6}|(\\\\w{1,1}/\\\\w{3,5}|\\\\w{3,5})\\\\d{6})";
final String string = "5/SakaNa(N)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}