const regex = /(\\d{1,2}/\\w{4,9}\\((N|Naing|n|p|P|naing|Y|y|E|e)\\)\\d{5,6}|(\\w{1,1}/\\w{3,5}|\\w{3,5})\\d{6})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\\\d{1,2}\/\\\\w{4,9}\\\\((N|Naing|n|p|P|naing|Y|y|E|e)\\\\)\\\\d{5,6}|(\\\\w{1,1}\/\\\\w{3,5}|\\\\w{3,5})\\\\d{6})', '')
const str = `5/SakaNa(N)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}