import Foundation
let pattern = #"(\\d{1,2}/\\w{4,9}\\((N|Naing|n|p|P|naing|Y|y|E|e)\\)\\d{5,6}|(\\w{1,1}/\\w{3,5}|\\w{3,5})\\d{6})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"5/SakaNa(N)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}