re = /(\\d{1,2}\/\\w{4,9}\\((N|Naing|n|p|P|naing|Y|y|E|e)\\)\\d{5,6}|(\\w{1,1}\/\\w{3,5}|\\w{3,5})\\d{6})/
str = '5/SakaNa(N)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end