import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<label(?!.*preferredMaxLayoutWidth).*numberOfLines.*>)";
final String string = "\n"
+ "<label opaque=\"NO\" userInteractionEnabled=\"NO\" tag=\"5\" contentMode=\"left\" horizontalHuggingPriority=\"251\" verticalHuggingPriority=\"251\" text=\"Label\" lineBreakMode=\"tailTruncation\"=\"4\" baselineAdjustment=\"alignBaselines\" adjustsFontSizeToFit=\"NO\" translatesAutoresizingMaskIntoConstraints=\"NO\" id=\"fgY-Rp-veR\">\n"
+ "<rect key=\"frame\" x=\"6\" y=\"40\" width=\"288\" height=\"60\"/>\n"
+ "<animations/>\n"
+ "<constraints>\n"
+ "<constraint firstAttribute=\"height\" constant=\"60\" id=\"g3c-hD-Hf9\"/>\n"
+ "</constraints>\n"
+ "<fontDescription key=\"fontDescription\" type=\"system\" pointSize=\"12\"/>\n"
+ "<color key=\"textColor\" red=\"0.0\" green=\"0.0\" blue=\"0.0\" alpha=\"1\" colorSpace=\"calibratedRGB\"/>\n"
+ "<nil key=\"highlightedColor\"/>\n"
+ "</label>\n"
+ "<label opaque=\"NO\" userInteractionEnabled=\"NO\" numberOfLines=\"4\" tag=\"10\" contentMode=\"left\" text=\"feedback\" lineBreakMode=\"tailTruncation\" numberOfLines=\"4\" baselineAdjustment=\"alignBaselines\" adjustsFontSizeToFit=\"NO\" translatesAutoresizingMaskIntoConstraints=\"NO\" id=\"M98-QE-PMx\">\n"
+ " <rect key=\"frame\" x=\"7\" y=\"227\" width=\"287\" height=\"70\"/>\n"
+ " <animations/>\n"
+ " <constraints>\n"
+ " <constraint firstAttribute=\"height\" constant=\"70\" id=\"uPb-iM-7XM\"/>\n"
+ " </constraints>\n"
+ " <fontDescription key=\"fontDescription\" type=\"system\" pointSize=\"14\"/>\n"
+ " <color key=\"textColor\" red=\"0.058823529409999999\" green=\"0.51372549020000002\" blue=\"0.94901960780000005\" alpha=\"1\" colorSpace=\"calibratedRGB\"/>\n"
+ " <nil key=\"highlightedColor\"/>\n"
+ " </label>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}