$re = '/(<label(?!.*preferredMaxLayoutWidth).*numberOfLines.*>)/';
$str = '
<label opaque="NO" userInteractionEnabled="NO" tag="5" contentMode="left" horizontalHuggingPriority="251" verticalHuggingPriority="251" text="Label" lineBreakMode="tailTruncation"="4" baselineAdjustment="alignBaselines" adjustsFontSizeToFit="NO" translatesAutoresizingMaskIntoConstraints="NO" id="fgY-Rp-veR">
<rect key="frame" x="6" y="40" width="288" height="60"/>
<animations/>
<constraints>
<constraint firstAttribute="height" constant="60" id="g3c-hD-Hf9"/>
</constraints>
<fontDescription key="fontDescription" type="system" pointSize="12"/>
<color key="textColor" red="0.0" green="0.0" blue="0.0" alpha="1" colorSpace="calibratedRGB"/>
<nil key="highlightedColor"/>
</label>
<label opaque="NO" userInteractionEnabled="NO" numberOfLines="4" tag="10" contentMode="left" text="feedback" lineBreakMode="tailTruncation" numberOfLines="4" baselineAdjustment="alignBaselines" adjustsFontSizeToFit="NO" translatesAutoresizingMaskIntoConstraints="NO" id="M98-QE-PMx">
<rect key="frame" x="7" y="227" width="287" height="70"/>
<animations/>
<constraints>
<constraint firstAttribute="height" constant="70" id="uPb-iM-7XM"/>
</constraints>
<fontDescription key="fontDescription" type="system" pointSize="14"/>
<color key="textColor" red="0.058823529409999999" green="0.51372549020000002" blue="0.94901960780000005" alpha="1" colorSpace="calibratedRGB"/>
<nil key="highlightedColor"/>
</label>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;