# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"\s?(.*)\s\((.*)\)"/Title: \1/g;t' <<< "\"S 4dr Sedan (1.8L 4cyl 4A)\"
\"CE 4dr Sedan (1.8L 4cyl 4A)\"
\"LE 4dr Sedan (1.8L 4cyl 5M)\"
\"LE 4dr Sedan (1.8L 4cyl 4A)\""