const regex = /"\s?(.*)\s\((.*)\)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('"\\s?(.*)\\s\\((.*)\\)"', 'g')
const str = `"S 4dr Sedan (1.8L 4cyl 4A)"
"CE 4dr Sedan (1.8L 4cyl 4A)"
"LE 4dr Sedan (1.8L 4cyl 5M)"
"LE 4dr Sedan (1.8L 4cyl 4A)"`;
const subst = `Title: \1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);