$re = '/(?:([A-Za-z]+):\/\/)?(?:([A-Za-z0-9]+)\:([A-Za-z0-9]+)\@)?((?:[A-Za-z0-9]+\.)+[A-Za-z0-9]+)(?:\:([0-9]+))?(?:\/((?:[A-Za-z0-9]+)(?:\/[A-Za-z0-9]+)*(?:\.[A-Za-z0-9]+)?)?(\?[A-Za-z0-9]+=[A-Za-z0-9]+(?:&[A-Za-z0-9]+=[A-Za-z0-9]+)*)?(?:#([A-Za-z0-9]+))?)?/';
$str = 'http://root:123@google.com:80/search/wtf?qqqq=123&www=456#result
http://google.com/page/page.html
http://www.google.com/page?qqqq=123
omg.wtf.google.com/page/page.wtf?qqqq=123&eee=455&4444=445
lol.com/page#anchor
lol.com/page.php#ancohr
wtf.omg/?param=value
wtf.omg/#anchor
root:123@myhost.org/page.php#anchor
root:123@wtf.omg.lol.com/?param=233#anchor';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);