import Foundation
let pattern = ##"(?:([A-Za-z]+):\/\/)?(?:([A-Za-z0-9]+)\:([A-Za-z0-9]+)\@)?((?:[A-Za-z0-9]+\.)+[A-Za-z0-9]+)(?:\:([0-9]+))?(?:\/((?:[A-Za-z0-9]+)(?:\/[A-Za-z0-9]+)*(?:\.[A-Za-z0-9]+)?)?(\?[A-Za-z0-9]+=[A-Za-z0-9]+(?:&[A-Za-z0-9]+=[A-Za-z0-9]+)*)?(?:#([A-Za-z0-9]+))?)?"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
http://root:123@google.com:80/search/wtf?qqqq=123&www=456#result
http://google.com/page/page.html
http://www.google.com/page?qqqq=123
omg.wtf.google.com/page/page.wtf?qqqq=123&eee=455&4444=445
lol.com/page#anchor
lol.com/page.php#ancohr
wtf.omg/?param=value
wtf.omg/#anchor
root:123@myhost.org/page.php#anchor
root:123@wtf.omg.lol.com/?param=233#anchor
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)