// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:([A-Za-z]+):\/\/)?(?:([A-Za-z0-9]+)\:([A-Za-z0-9]+)\@)?((?:[A-Za-z0-9]+\.)+[A-Za-z0-9]+)(?:\:([0-9]+))?(?:\/((?:[A-Za-z0-9]+)(?:\/[A-Za-z0-9]+)*(?:\.[A-Za-z0-9]+)?)?(\?[A-Za-z0-9]+=[A-Za-z0-9]+(?:&[A-Za-z0-9]+=[A-Za-z0-9]+)*)?(?:#([A-Za-z0-9]+))?)?").unwrap();
let string = "http://root:123@google.com:80/search/wtf?qqqq=123&www=456#result
http://google.com/page/page.html
http://www.google.com/page?qqqq=123
omg.wtf.google.com/page/page.wtf?qqqq=123&eee=455&4444=445
lol.com/page#anchor
lol.com/page.php#ancohr
wtf.omg/?param=value
wtf.omg/#anchor
root:123@myhost.org/page.php#anchor
root:123@wtf.omg.lol.com/?param=233#anchor";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}